subprocess.CalledProcessError

Having problems with building or using the CefSharp .NET binding? Ask your CEF-related questions here. Please ask general usage questions on StackOverflow.

Moderator: amaitland

subprocess.CalledProcessError

Postby nycrox34 » Sat Feb 20, 2021 3:40 am

what is this ?

Image
nycrox34
Newbie
 
Posts: 7
Joined: Sat Feb 20, 2021 1:21 am

Re: subprocess.CalledProcessError

Postby magreenblatt » Sat Feb 20, 2021 9:39 am

Could be the same as viewtopic.php?f=6&t=18217
magreenblatt
Site Admin
 
Posts: 10923
Joined: Fri May 29, 2009 6:57 pm

Re: subprocess.CalledProcessError

Postby nycrox34 » Sun Feb 21, 2021 2:53 am

Image

the problem still continues help
my current sdk : 10.0.19041
nycrox34
Newbie
 
Posts: 7
Joined: Sat Feb 20, 2021 1:21 am

Re: subprocess.CalledProcessError

Postby magreenblatt » Sun Feb 21, 2021 11:27 am

Please provide text instead of screenshots. The relevant error is lost off the top of the output that you provided.
magreenblatt
Site Admin
 
Posts: 10923
Joined: Fri May 29, 2009 6:57 pm

Re: subprocess.CalledProcessError

Postby nycrox34 » Sun Feb 21, 2021 5:38 pm

Code: Select all
Traceback (most recent call last):
  File "c:/code/chromium_git/chromium/src/build/vs_toolchain.py", line 588, in <module>
    sys.exit(main())
  File "c:/code/chromium_git/chromium/src/build/vs_toolchain.py", line 584, in main
    return commands[sys.argv[1]](*sys.argv[2:])
  File "c:/code/chromium_git/chromium/src/build/vs_toolchain.py", line 398, in CopyDlls
    _CopyRuntime(target_dir, runtime_dir, target_cpu, debug=True)
  File "c:/code/chromium_git/chromium/src/build/vs_toolchain.py", line 371, in _CopyRuntime
    _CopyUCRTRuntime(target_dir, source_dir, target_cpu, suffix)
  File "c:/code/chromium_git/chromium/src/build/vs_toolchain.py", line 289, in _CopyUCRTRuntime
    _CopyRuntimeImpl(target, source)
  File "c:/code/chromium_git/chromium/src/build/vs_toolchain.py", line 240, in _CopyRuntimeImpl
    shutil.copy2(source, target)
  File "c:\code\depot_tools\bootstrap-3_8_0_chromium_8_bin\python\bin\lib\shutil.py", line 153, in copy2
    copyfile(src, dst)
  File "c:\code\depot_tools\bootstrap-3_8_0_chromium_8_bin\python\bin\lib\shutil.py", line 96, in copyfile
    with open(src, 'rb') as fsrc:
IOError: [Errno 2] No such file or directory: 'C:\\Windows\\SysWOW64\\msvcp140d.dll'
Traceback (most recent call last):
  File "c:\code\chromium_git\chromium\src\cef\tools\gclient_hook.py", line 143, in <module>
    RunAction(src_dir, cmd)
  File "c:\code\chromium_git\chromium\src\cef\tools\gclient_util.py", line 36, in RunAction
    command, cwd=dir, always_show_header=True, print_stdout=True)
  File "c:\code\depot_tools\gclient_utils.py", line 673, in CheckCallAndFilter
    rv, args, kwargs.get('cwd', None), None, None)
subprocess2.CalledProcessError: Command 'gn gen out\\Debug_GN_x86 --ide=vs2019 --sln=cef --filters=//cef/*' returned non-zero exit status 1 in c:\code\chromium_git\chromium\src
Traceback (most recent call last):
  File "..\automate\automate-git.py", line 1462, in <module>
    run('%s %s' % (python_exe, tool), cef_src_dir, depot_tools_dir)
  File "..\automate\automate-git.py", line 70, in run
    args, cwd=working_dir, env=env, shell=(sys.platform == 'win32'))
  File "C:\code\depot_tools\bootstrap-3_8_0_chromium_8_bin\python\bin\lib\subprocess.py", line 190, in check_call
    raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command '['c:\\code\\depot_tools\\python.bat', 'c:\\code\\chromium_git\\chromium\\src\\cef\\tools\\gclient_hook.py']' returned non-zero exit status 1


And manual debug subprocess2 error

Code: Select all
Traceback (most recent call last):
  File "C:/code/chromium_git/chromium/src/build/toolchain/win/setup_toolchain.py", line 302, in <module>
    main()
  File "C:/code/chromium_git/chromium/src/build/toolchain/win/setup_toolchain.py", line 251, in main
    vc_bin_dir = FindFileInEnvList(env, 'PATH', os.pathsep, 'cl.exe')
  File "C:/code/chromium_git/chromium/src/build/toolchain/win/setup_toolchain.py", line 209, in FindFileInEnvList
    file_name, env_name, '\n'.join(parts))
AssertionError: cl.exe is not found in PATH:
C:\Windows\System32
C:\Windows\SysWOW64
Arm64Unused
C:\code\depot_tools\bootstrap-3_8_0_chromium_8_bin\python\bin
C:\code\depot_tools\bootstrap-3_8_0_chromium_8_bin\python\bin
C:\code\depot_tools\bootstrap-3_8_0_chromium_8_bin\python\bin\Scripts
C:\Windows\system32
C:\Windows
C:\Windows\System32\Wbem
C:\Windows\System32\WindowsPowerShell\v1.0\
C:\Windows\System32\OpenSSH\
C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common
C:\Program Files\NVIDIA Corporation\NVIDIA NvDLISR
C:\Program Files (x86)\Windows Kits\8.1\Windows Performance Toolkit\
C:\Program Files\Microsoft SQL Server\110\Tools\Binn\
C:\Program Files (x86)\Microsoft SDKs\TypeScript\1.0\
C:\Program Files\Microsoft SQL Server\120\Tools\Binn\
C:\Program Files\Microsoft\Web Platform Installer\
C:\Program Files\dotnet\
C:\Program Files\Microsoft SQL Server\130\Tools\Binn\
C:\code\depot_tools
C:\Program Files (x86)\Windows Kits\10\Windows Performance Toolkit\
C:\code\depot_tools
C:\Users\Cry_x\.dotnet\tools
C:\code\depot_tools\
Check if it is installed.
Traceback (most recent call last):
  File "tools\gclient_hook.py", line 143, in <module>
    RunAction(src_dir, cmd)
  File "C:\code\chromium_git\chromium\src\cef\tools\gclient_util.py", line 36, in RunAction
    command, cwd=dir, always_show_header=True, print_stdout=True)
  File "C:\code\depot_tools\gclient_utils.py", line 673, in CheckCallAndFilter
    rv, args, kwargs.get('cwd', None), None, None)
subprocess2.CalledProcessError: Command 'gn gen out\\Debug_GN_x86 --ide=vs2019 --sln=cef --filters=//cef/*' returned non-zero exit status 1 in C:\code\chromium_git\chromium\src
C:\code\chromium_git\chromium\src\cef>
nycrox34
Newbie
 
Posts: 7
Joined: Sat Feb 20, 2021 1:21 am

Re: subprocess.CalledProcessError

Postby magreenblatt » Sun Feb 21, 2021 6:02 pm

Do you have Visual Studio 2017 or 2019 installed in the default location? The required sub-components are listed at https://bitbucket.org/chromiumembedded/ ... figuration
magreenblatt
Site Admin
 
Posts: 10923
Joined: Fri May 29, 2009 6:57 pm

Re: subprocess.CalledProcessError

Postby nycrox34 » Sun Feb 21, 2021 6:05 pm

C:\Program Files (x86)\Microsoft Visual Studio\2019\Professional\Common7\IDE its vs2019 path
nycrox34
Newbie
 
Posts: 7
Joined: Sat Feb 20, 2021 1:21 am

Re: subprocess.CalledProcessError

Postby nycrox34 » Sun Feb 21, 2021 6:16 pm

Code: Select all
$ PATH_TO_INSTALLER.EXE ^
--add Microsoft.VisualStudio.Workload.NativeDesktop ^
--add Microsoft.VisualStudio.Component.VC.ATLMFC ^
--includeRecommended


Where to write these codes, can you help me?
nycrox34
Newbie
 
Posts: 7
Joined: Sat Feb 20, 2021 1:21 am

Re: subprocess.CalledProcessError

Postby ndesktop » Mon Feb 22, 2021 4:29 am

Console launch as administrator. Locate visual studio installer and issue the command as recommended.
ndesktop
Master
 
Posts: 557
Joined: Thu Dec 03, 2015 10:10 am


Return to CefSharp Forum

Who is online

Users browsing this forum: No registered users and 1 guest

cron