--enable-media-stream switch is not responding

Having problems with building or using the JCEF Java binding? Ask your questions here.

--enable-media-stream switch is not responding

Postby mathics » Thu Oct 31, 2019 2:43 am

I am trying to give --enable-media-stream switch for the program that I am building using jcef. I am tried to turn on switch with the following cases:
Code: Select all
        settings.windowless_rendering_enabled = useOSR;
        settings.command_line_args_disabled = false;
        String[] args = new String[]{
               // "--enable-media-steam",
               // "enable-media-stream", "1"

        cefApp = CefApp.getInstance(args, settings);

Program gives [1031/094701.279:INFO:CONSOLE(0)] "Uncaught (in promise) NotAllowedError: Permission denied", source: theUrl error in every cases.
However, camera is allowed if I run *.jar app from commandline with: "java -jar appName.jar --enable-media-stream" command.
What might be the issue here?
Thanks in advance.
Posts: 1
Joined: Thu Oct 31, 2019 2:35 am

Re: --enable-media-stream switch is not responding

Postby Czarek » Tue Nov 05, 2019 4:25 am

Try adding the switch via CefAppHandlerAdapter::onBeforeCommandLineProcessing callback.
Maintainer of the CEF Python, PHP Desktop and CEF C API projects. I'm available for contract work, see my resume.
User avatar
Posts: 1829
Joined: Sun Nov 06, 2011 2:12 am

Return to JCEF Forum

Who is online

Users browsing this forum: No registered users and 1 guest