make -j4 failed

Having problems with building or using the JCEF Java binding? Ask your questions here.

make -j4 failed

Postby nefarious » Tue Jan 29, 2019 2:41 am

I'm sure you are tired of this question by now, I tried to search for it and fond no reference.

I am trying to build jcef on ubuntu linux following the instructions on the wike. Some things didn't seem to be correct, so maybe I did something really stupid. It has happened before.

I downloaded the src with

git clone https://bitbucket.org/chromiumembedded/java-cef.git src

and this seemed to work. I cd to src.

I made the directory jcef_build ok, but when I went to the directory and tried to run cmake, I got the message that the directory didn't contain CMakeList.txt. the src directory did so I copied the file and then ran cmake again. I got the message Unknown CMake command "DownloadCEF" so I figured this was wrong. so I removed all of the files in the directory and went back to the src directory and ran cmake. This seems to have worked, with no errors.

I then ran make -j4 and it quits after a while with:
[ 70%] Built target libcef_dll_wrapper
[ 70%] Linking CXX executable Release/jcef_helper
/usr/bin/ld: cannot find -lX11
collect2: error: ld returned 1 exit status
native/CMakeFiles/jcef_helper.dir/build.make:122: recipe for target 'native/Release/jcef_helper' failed
make[2]: *** [native/Release/jcef_helper] Error 1
CMakeFiles/Makefile2:180: recipe for target 'native/CMakeFiles/jcef_helper.dir/all' failed
make[1]: *** [native/CMakeFiles/jcef_helper.dir/all] Error 2
Makefile:83: recipe for target 'all' failed
make: *** [all] Error 2

so I checked if the library is installed wirh
ldconfig -p | grep X11 and get
libX11.so.6 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libX11.so.6
libX11-xcb.so.1 (libc6,x86-64) => /usr/lib/x86_64-linux-gnu/libX11-xcb.so.1
so libX11 is availabile so maybe this command needs to be run with sudo:

and this has the same issue. What did I do wrong?
nefarious
Newbie
 
Posts: 1
Joined: Tue Jan 29, 2019 2:20 am

Re: make -j4 failed

Postby magreenblatt » Tue Jan 29, 2019 12:44 pm

Have you installed the libx11-dev package?
magreenblatt
Site Admin
 
Posts: 9837
Joined: Fri May 29, 2009 6:57 pm


Return to JCEF Forum

Who is online

Users browsing this forum: No registered users and 3 guests