Debugging cefclient app in mac os x 10.7

Built a cool app using CEF that you'd like to share with the community? Talk about it here.

Debugging cefclient app in mac os x 10.7

Postby dhiren » Sat Nov 12, 2011 3:41 pm

Hi

I downloaded cef_binary_r365_macosx.zip today.
I have built the cefclient app successully on my Mac os x lion and i can run the app.
But i wanted to debug it, i have given a breakpoint in the main function in cefclient_mac.mm, but its not hitting the breakpoint. The application just starts running.
Is there any project setting i have to change for debugging. I am using xCode 4.1.

Thanks,
Dhiren
dhiren
Newbie
 
Posts: 2
Joined: Sat Nov 12, 2011 3:34 pm

Re: Debugging cefclient app in mac os x 10.7

Postby magreenblatt » Sat Nov 12, 2011 8:02 pm

Are you sure you're running in debug mode? If you're unfamiliar with the Xcode 4 debugger you can find more information here: http://developer.apple.com/library/mac/ ... gging.html
magreenblatt
Site Admin
 
Posts: 9831
Joined: Fri May 29, 2009 6:57 pm

Re: Debugging cefclient app in mac os x 10.7

Postby dhiren » Sun Nov 13, 2011 1:53 am

Yes i am running in debug mode, otherwise the application would have been created in a Release folder inside xcodebuild folder, but it was created in Debug folder.
I have checked the run settings in scheme also, its debug.
Anyhow it should enter the main method in cefclient_mac.mm, where the breakpoint is.
dhiren
Newbie
 
Posts: 2
Joined: Sat Nov 12, 2011 3:34 pm

Re: Debugging cefclient app in mac os x 10.7

Postby magreenblatt » Sun Nov 13, 2011 9:49 am

Building in Debug mode is not the same as running using the debugger.
magreenblatt
Site Admin
 
Posts: 9831
Joined: Fri May 29, 2009 6:57 pm


Return to Apps Discussion

Who is online

Users browsing this forum: No registered users and 1 guest

cron