/lib64/libm.so.6: version `GLIBC_2.27' not found (required b

Do not post support requests, bug reports or feature requests. Discuss CEF here. Non-CEF related discussion goes in General Discussion!

/lib64/libm.so.6: version `GLIBC_2.27' not found (required b

Postby Guang » Wed Nov 25, 2020 2:32 am

I build the CEF on the server and got an error when I executed on another server:
[root@localhost software]# cd Release/
[root@localhost Release]# ll
total 1045648
-rw-rw-r--. 1 ubuntu ubuntu 756795 Nov 24 15:39 cef_100_percent.pak
-rw-rw-r--. 1 ubuntu ubuntu 909762 Nov 24 15:39 cef_200_percent.pak
-rw-rw-r--. 1 ubuntu ubuntu 1721342 Nov 24 15:39 cef_extensions.pak
-rw-rw-r--. 1 ubuntu ubuntu 2905564 Nov 24 15:39 cef.pak
-rwxrwxr-x. 1 ubuntu ubuntu 1238568 Nov 25 14:21 cefsimple
-rwxrwxr-x. 1 ubuntu ubuntu 1605688 Nov 25 14:17 chrome-sandbox
-rw-r--r--. 1 ubuntu ubuntu 80548263 Nov 25 14:22 debug.log
-rw-rw-r--. 1 ubuntu ubuntu 6323508 Nov 24 15:39 devtools_resources.pak
drwx------. 2 ubuntu ubuntu 75 Nov 24 15:49 GPUCache
-rw-rw-r--. 1 ubuntu ubuntu 10426784 Nov 24 15:39 icudtl.dat
-rwxrwxr-x. 1 ubuntu ubuntu 922848792 Nov 25 14:17 libcef.so
-rwxrwxr-x. 1 ubuntu ubuntu 1792088 Nov 25 14:17 libEGL.so
-rwxrwxr-x. 1 ubuntu ubuntu 38561848 Nov 25 14:17 libGLESv2.so
drwxrwxr-x. 2 ubuntu ubuntu 4096 Nov 25 14:21 locales
-rw-rw-r--. 1 ubuntu ubuntu 82118 Nov 24 15:39 natives_blob.bin
-rw-rw-r--. 1 ubuntu ubuntu 280392 Nov 24 15:39 snapshot_blob.bin
drwxrwxr-x. 2 ubuntu ubuntu 43 Nov 25 14:21 swiftshader
-rw-rw-r--. 1 ubuntu ubuntu 701504 Nov 24 15:39 v8_context_snapshot.bin
[root@localhost Release]# ./cefsimple
./cefsimple: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by ./cefsimple)
./cefsimple: /lib64/libm.so.6: version `GLIBC_2.27' not found (required by ./libcef.so)
[root@localhost Release]#



Can someone help me see why, thank you !
Last edited by Guang on Wed Nov 25, 2020 9:06 pm, edited 1 time in total.
Guang
Newbie
 
Posts: 2
Joined: Wed Nov 25, 2020 2:27 am

Re: /lib64/libm.so.6: version `GLIBC_2.27' not found (requir

Postby magreenblatt » Wed Nov 25, 2020 10:16 am

Did you build with use_sysroot=true? See https://bitbucket.org/chromiumembedded/ ... figuration
magreenblatt
Site Admin
 
Posts: 11088
Joined: Fri May 29, 2009 6:57 pm

Re: /lib64/libm.so.6: version `GLIBC_2.27' not found (requir

Postby Guang » Thu Nov 26, 2020 2:17 am

magreenblatt wrote:Did you build with use_sysroot=true? See https://bitbucket.org/chromiumembedded/ ... figuration

Oh, I did what you said. it worked, thank you very much!
Guang
Newbie
 
Posts: 2
Joined: Wed Nov 25, 2020 2:27 am


Return to CEF Discussion

Who is online

Users browsing this forum: No registered users and 2 guests