CEF+OZONE+CHROMIUM+Threads using wrong paths?

Do not post support requests, bug reports or feature requests. Discuss CEF here. Non-CEF related discussion goes in General Discussion!

CEF+OZONE+CHROMIUM+Threads using wrong paths?

Postby ildefonso » Fri Aug 05, 2016 11:47 am

Hello,
I am trying to build CEF with ozone + libcaca to get something similar to this:
https://www.chromium.org/developers/design-documents/ozone
but with cefsimple instead content shell.

I studied this old port:https://github.com/kuscsik/chromiumembedded/tree/aura
and I made similar changes, (removing X11 dependecies and using Aura for window creation) and it builds,

however when I run it, I start to get these types of errors:
Check failed: CEF_CURRENTLY_ON(content::BrowserThread::IO).

which makes me think a thread is calling a function/code it should NOT be calling.
and if I remove the check it fails later because a pointer (which I don't remember) should not be zero, which means the state is not valid.

[*]Some ideas why this could be happening ? a thread executing the wrong code?
[*]any advise on porting CEF with Ozone support? (aka. what I should be aware or how to do it? :) )

I am using ubuntu 14.04 (3.19.0-65)

full error stack:
./out/Debug/cefsimple --disable-gpu-shader-disk-cache --disable-setuid-sandbox --ozone-platform=caca
[0804/161026:ERROR:browser_main_loop.cc(231)] Running without the SUID sandbox! See https://chromium.googlesource.com/chrom ... lopment.md for more information on developing with the sandbox on.
[0804/161027:WARNING:audio_manager.cc(297)] Multiple instances of AudioManager detected
[0804/161027:WARNING:audio_manager.cc(271)] Multiple instances of AudioManager detected
[0804/161027:ERROR:sandbox_linux.cc(343)] InitializeSandbox() called with multiple threads in process gpu-process.
[0804/161027:FATAL:content_browser_client.cc(699)] Check failed: CEF_CURRENTLY_ON(content::BrowserThread::IO).
#0 0x7f1b510cd2fe base::debug::StackTrace::StackTrace()
#1 0x7f1b511199ef logging::LogMessage::~LogMessage()
#2 0x7f1b50dc7e90 CefContentBrowserClient::CanCreateWindow()
#3 0x7f1b58c497e1 content::PlatformNotificationContextImpl::Initialize()
#4 0x7f1b58ff5628 content::StoragePartitionImpl::Create()
#5 0x7f1b59002f86 content::StoragePartitionImplMap::Get()
#6 0x7f1b58697cff content::(anonymous namespace)::GetStoragePartitionFromConfig()
#7 0x7f1b58697c80 content::BrowserContext::GetStoragePartition()
#8 0x7f1b58697e49 content::BrowserContext::GetDefaultStoragePartition()
#9 0x7f1b50d54f12 CefBrowserContext::GetRequestContext()
#10 0x7f1b50d586da CefBrowserContextImpl::Initialize()
#11 0x7f1b50db0969 CefBrowserMainParts::PreMainMessageLoopRun()
#12 0x7f1b586a5164 content::BrowserMainLoop::PreMainMessageLoopRun()
#13 0x7f1b50dd3380 _ZN4base8internal15RunnableAdapterIM10CefContextFvvEE3RunIPS2_JEEEvOT_DpOT0_
#14 0x7f1b50dd32e9 _ZN4base8internal12InvokeHelperILb0EvNS0_15RunnableAdapterIM10CefContextFvvEEEE8MakeItSoIJPS3_EEEvS6_DpOT_
#15 0x7f1b586acf2d _ZN4base8internal7InvokerINS_13IndexSequenceIJLm0EEEENS0_9BindStateINS0_15RunnableAdapterIMN7content15BrowserMainLoopEFivEEEFiPS7_EJNS0_17UnretainedWrapperIS7_EEEEENS0_12InvokeHelperILb0EiSA_EEFivEE3RunEPNS0_13BindStateBaseE
#16 0x7f1b50ddd4be base::Callback<>::Run()
#17 0x7f1b58ff285b content::StartupTaskRunner::RunAllTasksNow()
#18 0x7f1b586a3335 content::BrowserMainLoop::CreateStartupTasks()
#19 0x7f1b586ae37d content::BrowserMainRunnerImpl::Initialize()
#20 0x7f1b50f204b4 CefMainDelegate::RunProcess()
#21 0x7f1b59777dab content::RunNamedProcessTypeMain()
#22 0x7f1b59779ca2 content::ContentMainRunnerImpl::Run()
#23 0x7f1b50dd071c CefContext::Initialize()
#24 0x7f1b50dd036a CefInitialize()
#25 0x7f1b50c16af3 cef_initialize
#26 0x000000410f67 CefInitialize()
#27 0x00000040ea3d main
#28 0x7f1b4f304f45 __libc_start_main
#29 0x0000004060d4 <unknown>


notes:
--disable-gpu-shader-disk-cache : I got a segment fault that went away by using this flag.
ildefonso
Newbie
 
Posts: 1
Joined: Fri Aug 05, 2016 10:07 am

Re: CEF+OZONE+CHROMIUM+Threads using wrong paths?

Postby lagnat » Fri Dec 09, 2016 9:20 pm

Did you ever get this working?

Thanks..
lagnat
Newbie
 
Posts: 2
Joined: Fri Dec 09, 2016 7:57 pm


Return to CEF Discussion

Who is online

Users browsing this forum: No registered users and 5 guests