Porting CEF3 on ARM

Do not post support requests, bug reports or feature requests. Discuss CEF here. Non-CEF related discussion goes in General Discussion!

Re: Porting CEF3 on ARM

Postby MaitreDede » Tue Jul 05, 2016 9:25 pm

Hi,

Did you succeeded to have CEF3 work on ARM with no X11 ?

I would like to achieve the same goal, on Raspberry Pi, but I have not yet found a walkthrough from a vanilla Raspbian...
Coding bugs...
User avatar
MaitreDede
Newbie
 
Posts: 6
Joined: Mon Jul 04, 2016 3:59 pm
Location: New Caledonia

Re: Porting CEF3 on ARM

Postby magreenblatt » Fri Sep 09, 2016 2:14 pm

magreenblatt
Site Admin
 
Posts: 10748
Joined: Fri May 29, 2009 6:57 pm

Re: Porting CEF3 on ARM

Postby PauloZambrotta » Fri Nov 11, 2016 11:27 am

Hi
I have built CEF for iMX6 following instructions and tips from this forum.
But I do not know what kind of performance I should expect.
At the moment:
1)for url: https://developer.microsoft.com/en-us/m ... ishietank/
if resolution is 1920x1080 then OnFrameCaptureSuccess() is called 0.7 times per second
if res is 1920x540 it is called 1.5 times per second
960x540 then OnFrameCaptureSuccess() is called 3 times per second
and eventually if I the resolution is 240x270 then OnFrameCaptureSuccess() is called almost 30times per second.
The website itself shows fps but the numbers are higher than the number of OnPaint calls e.g. the shown fps for 1080p is 5-8 instead of 0.7
2)http://wpsites.net/web-design/scrolling-text-images-html-effects/
I have got 1.5fps for 1080p
6.4fps for 960x540
11.6fps for 960x270

Is this performance everything I can get with directfb instead of X11 and with gpu-disabled?
I have yocto 1.5. Should I expect better performance with newer yocto e.g. 1.7?

Apologies if the answers to my questions are obvious but it is all new to me.
PauloZambrotta
Newbie
 
Posts: 1
Joined: Thu Oct 06, 2016 3:22 am

Re: Porting CEF3 on ARM

Postby Bizhan » Mon Dec 05, 2016 2:00 pm

Hello,
I am trying to follow up the instruction on this thread to cross compile libcef for arm on a system with no x11.

The issue I get is:
./build/gyp_chromium
Updating projects from gyp files...
gyp: usage: gyp_chromium [options ...] [build_file ...]

gyp_chromium: error: no build_file


What build file should I pass to "./build/gyp_chromium". The original code does not have any options...
Thanks,
B
Bizhan
Newbie
 
Posts: 1
Joined: Mon Dec 05, 2016 8:20 am

Re: Porting CEF3 on ARM

Postby magreenblatt » Tue Dec 06, 2016 4:15 am

Bizhan wrote:I am trying to follow up the instruction on this thread to cross compile libcef for arm on a system with no x11.

X11 is still required. You should follow the instructions at https://bitbucket.org/chromiumembedded/ ... t-30495117
magreenblatt
Site Admin
 
Posts: 10748
Joined: Fri May 29, 2009 6:57 pm

Previous

Return to CEF Discussion

Who is online

Users browsing this forum: No registered users and 1 guest