Possible issue with CEFGlue + proxy with authentication.

Having problems with building or using the CefGlue .NET/Mono binding? Ask your questions here.

Moderator: fddima

Possible issue with CEFGlue + proxy with authentication.

Postby rodrigobarros » Tue Oct 10, 2017 2:11 pm

Hi All!

There is a possible issue with CEFGlue + proxy with authentication. I´d like to ask some help in order to confirm and properly address it:

Since CEFGlue v2743 (CEFv53), we are experiencing a hang due to some sort of concurrency with dialog implemented to input proxy credentials.

Our investigation suggests that latest OK version is CEFGlue with CEFv51. All versions after that presents the problem in which user has to force close the application.

It has been tested on Chromium versions after CEFv51 and issue is not present. It has also tested on CefSharp with CEF59 and issue is not present as well.

By testing our code with CEF + CEFGlue v51, issue is not reproduced. When using CEF + CEFGlue v59, issue is back reproduced.

We´ve having trouble to apply GetAuthCredentials change on CEFGlue demo app in order to test solely on CEFGlue. We´re overriding GetAuthCredentials on Xilium.CefGlue.Demo.Browser.WebRequestHandler but execution dont touch it. Is this the right place to apply the Dialog to request login credentials on?

In order to test it, I have just enabled CEFGlue to point to a configured proxy with basic authentication.

Thanks!
rodrigobarros
Newbie
 
Posts: 8
Joined: Wed Nov 02, 2016 1:52 pm

Return to CefGlue Forum

Who is online

Users browsing this forum: No registered users and 3 guests